Description
The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (`wp_ajax_nopriv_*`) that fail to implement proper `current_user_can()` authorization checks. While these handlers use ACF's `acf_verify_ajax()` function to validate cryptographic nonces, the `acf_nonce` values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.
References7
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/…
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/…
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/…
- plugins.trac.wordpress.org/browser/acf-extended/trunk/includes/…
- plugins.trac.wordpress.org/changeset/3516027/
- plugins.trac.wordpress.org/changeset/3754818/
- www.wordfence.com/threat-intel/vulnerabilities/id/9954ef37-bae0…
Metrics
- CVSS 3.1
-
5.3
MEDIUM
Score source: CNA
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N - EPSS — exploit probability
- 0% percentile: 20 · as of 3 November 2026
- CWE
- CWE-862
Could this be exploited in your environment?
A patch closes the known hole. A penetration test shows what an attacker can still reach — with proof.