עברית

Vulnerability Intelligence

CVE-2026-19633

High 8.8

Published
Last modified
NVD status
Awaiting Analysis

Description

PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to execute arbitrary code by abusing operators, domain casts, or view subqueries that carry untrusted expressions. When these objects are evaluated in the context of the extension’s masking mechanisms, the malicious code can run with elevated privileges. The issue is fixed in PostgreSQL Anonymizer 3.1.4 and later versions

References1

Metrics

CVSS 3.1
8.8 HIGH Score source: CNA CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS — exploit probability
1% percentile: 53 · as of 3 November 2026
CWE
CWE-89

Could this be exploited in your environment?

A patch closes the known hole. A penetration test shows what an attacker can still reach — with proof.