עברית

Vulnerability Intelligence

CVE-2026-105612

Low 3.5

Published
Last modified
NVD status
Awaiting Analysis

Description

PostgreSQL Anonymizer contains a vulnerability that data-modifying CTEs to bypass the read-only restriction of masked roles. The problem is resolved in PostgreSQL Anonymizer 3.3.0 and later versions

References1

Metrics

CVSS 3.1
3.5 LOW Score source: CNA CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS — exploit probability
0% percentile: 6 · as of 3 November 2026
CWE
CWE-862

Could this be exploited in your environment?

A patch closes the known hole. A penetration test shows what an attacker can still reach — with proof.