CVE-2025-24813
Critical 9.8 Exploited in the wild (KEV)
Confirmed active exploitation — CISA KEV catalog
- Name
- Apache Tomcat Path Equivalence Vulnerability
- Added to catalog
- Remediation due date (US federal)
- Required action
- Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Description
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Metrics
- CVSS 3.1
-
9.8 (CRITICAL)
Score source: NVD
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS — exploit probability
- 100% (percentile: 100) as of 1 November 2026
- CWE
- CWE-44, CWE-502, CWE-706
Affected products
apache: tomcat; debian: debian linux; netapp: bootstrap os; netapp: hci compute node
References
- https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq Vendor Advisory
- https://github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.md Exploit
- http://www.openwall.com/lists/oss-security/2025/03/10/5 Mailing ListThird Party Advisory
- https://lists.debian.org/debian-lts-announce/2025/04/msg00003.html Mailing ListThird Party Advisory
- https://security.netapp.com/advisory/ntap-20250321-0001/ Third Party Advisory
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rce Issue Tracking
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rce Issue Tracking
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerabili… Issue Tracking
- https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnera… Issue Tracking
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025… Third Party AdvisoryUS Government Resource