תיאור (מקור, אנגלית)
There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.
מוצרים מושפעים
apache: spark
קישורים2
- lists.apache.org/thread/k36prh3oxl1z6ov7w8rpmfnt07hmzw3v Mailing ListVendor Advisory
- www.openwall.com/lists/oss-security/2026/09/01/4 Mailing ListThird Party Advisory
מדדים
- CVSS 3.1
-
6.1
MEDIUM
מקור הציון: CNA
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - EPSS — סבירות ניצול
- 0% אחוזון 36 · נכון ל-7 בנובמבר 2026
- CWE
- CWE-80
האם אפשר לנצל את הפגיעות הזו אצלכם?
עדכון אבטחה סוגר את הפרצה הידועה. בדיקת חדירות מראה לאן תוקף עדיין יכול להגיע — עם הוכחה.