English

לוח פגיעויות

CVE-2022-49804

גבוהה 7.8

פורסם
עודכן לאחרונה
סטטוס ב-⁠NVD
Modified

תיאור (מקור, אנגלית)

In the Linux kernel, the following vulnerability has been resolved: s390: avoid using global register for current_stack_pointer Commit 30de14b1884b ("s390: current_stack_pointer shouldn't be a function") made current_stack_pointer a global register variable like on many other architectures. Unfortunately on s390 it uncovers old gcc bug which is fixed only since gcc-9.1 [gcc commit 3ad7fed1cc87 ("S/390: Fix PR89775. Stackpointer save/restore instructions removed")] and backported to gcc-8.4 and later. Due to this bug gcc versions prior to 8.4 generate broken code which leads to stack corruptions. Current minimal gcc version required to build the kernel is declared as 5.1. It is not possible to fix all old gcc versions, so work around this problem by avoiding using global register variable for current_stack_pointer.

מוצרים מושפעים

linux: linux kernel

קישורים2

מדדים

CVSS 3.1
7.8 HIGH מקור הציון: NVD CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS — סבירות ניצול
0% אחוזון 9 · נכון ל-7 בנובמבר 2026
CWE
CWE-787

האם אפשר לנצל את הפגיעות הזו אצלכם?

עדכון אבטחה סוגר את הפרצה הידועה. בדיקת חדירות מראה לאן תוקף עדיין יכול להגיע — עם הוכחה.